Zend Optimizer不支持php5.3的解决方案

Zend Optimizer已经不支持php5.3了,官方给出了ZendGuardLoader代替,安装和原版类似。
linux下版本下载:
wget -c http://downloads.zend.com/guard/5.5.0/ZendGuardLoader-php-5.3-linux-glibc23-i386.tar.gz
解压:tar -zxvf ZendGuardLoader-php-5.3-linux-glibc23-x86_64.tar.gz
cd ZendGuardLoader-php-5.3-linux-glibc23-x86_64
mkdir /usr/local/zend
cp php5.3.x/ZendGuardLoader.so  /usr/local/zend


然后在 php.ini中添加:
[Zend Guard Loader]
zend_extension="/usr/local/zend/ZendGuardLoader.so"
zend_loader.enable=1
zend_loader.disable_licensing=0
zend_loader.obfuscation_level_support=3
zend_loader.license_path=
或者
zend_extension=/usr/local/zend/ZendGuardLoader.so

然后重启php即可。
重启php时可能会出现如下错误:

Failed loading /usr/local/zend/ZendGuardLoader.so:  /usr/local/zend/ZendGuardLoader.so: cannot restore segment prot after reloc: Permission denied
解决办法:1、setenforce 0 或者vim /etc/sysconfig/selinux   SELINUX=disabled
2、chcon -t textrel_shlib_t /usr/local/zend/ZendOptimizer.so
用phpinfo测试下出现如下提示说明安装成功:

This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.3.0, Copyright (c) 1998-2011 Zend Technologies
    with Zend Guard Loader v3.3, Copyright (c) 1998-2010, by Zend Technologies

文章来自: 本站原创
引用通告: 查看所有引用 | 我要引用此文章
Tags:
相关日志:
评论: 0 | 引用: 0 | 查看次数: 463
发表评论
昵 称:
密 码: 游客发言不需要密码.
内 容:
验证码: 验证码
选 项:
虽然发表评论不用注册,但是为了保护您的发言权,建议您注册帐号.
字数限制 1000 字 | UBB代码 开启 | [img]标签 关闭